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Foreword

Congratulations! You just acquired the finest editor available for the MFC-101 MIDI controller from 
Fractal Audio Systems. The MFC-101 is an extremely capable device for controlling all your MIDI 
gear and it is especially useful for controlling your Axe-Fx product, particularly in a live performance
setting. In order to fully leverage the power of your MFC-101, you will need an equally powerful 
editor. While you can (and on occasion will) use the 21 steel footswitches on the MFC-101 to 
program the device, it is a rather daunting task. If you are changing your MFC-101 settings with 
any regularity, you will truly appreciate the MFC-Edit program. I personally leverage the MFC-101 
controller extensively and am constantly changing settings to control ever-changing equipment, 
presets, effects, songs and set lists. That is the reason I wrote the MFC-Edit program – to make 
these changes easily and reliably.

You MAC users don't need to feel excluded either – MFC-Edit works on your MAC as well as 
Windows. Even you techies using LINUX – it works great on LINUX too!

You'll find that MFC-Edit is organized in the way it is most frequently used. The screens that you 
use the most appear earlier in the sequence than those rarely used. That being said, there are 
users of the great device that don't use it with an Axe-Fx at all, so their screens will not seem to be 
“before” the others.

This program is written to be used and to be useful. I hope that you will find it as useful as I do 
myself.

Credits

Gary Heller – programming, documentation, release notes and online help.

Matt Picone – lots of support, ideas, advice and contacts for the SysEx protocol.

Todd Mizenko – for his great SysEx Protocol document and other help decoding the data stream.

Testing - Patrick Zagury, Steve Crosby, Joseph Karniewicz, Scott, John Evers, Joe Parr, Andrew 
Broughton, Andrew Sciascia, Jonah Carneskog, Sean Strickland and “axifist”, … and many others.

Fractal Audio systems – Special thanks to Cliff Chase and all the great folks at FAS who have 
accomplished something extraordinary in our world. May they continue to do so.

System Requirements

Microsoft Windows XP SP2, Windows 7, Windows 8, Vista, Windows 10 and any 
other that supports Oracle Java version 8 or greater

Apple MacOS 10.7 and greater, Mavericks, Yosemite, El Capitan. Sierra & High 
Sierra and any other that supports Oracle Java version 8 or greater

Linux Linux distributions that support Oracle Java version 8 or greater.  

NOTE: OpenJDK is not supported

Java Java version 1.8 (aka 8.0.25) 32-bit and 64-bit or newer

If you don't already have the right version of Java installed, you can download it from here:
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Download Java Runtime.

Supported Fractal Audio Systems Hardware and Firmware

MFC-Edit has been tested with and is known to work with:

 MFC-101 MK-I

 MFC-101 MK-II

 MFC-101 MK-III

 Firmware versions 2.15 and greater up to firmware version 3.08/3.8

 Axe-Fx Standard

 Axe-Fx Ultra

 Axe-Fx II  Mark-I and Mark-II

 Axe-Fx II XL

 Axe-Fx II XL+

 Axe-Fx III – Please see addendum

MFC-Edit is known to work with the following USB/MIDI Interfaces:

 Axe-Fx as a USB Interface

 Roland UM-One (my personal favorite)

 E-MU midi1X1

 CMD U2MIDI

 iConnectMIDI 4+

 … there are likely many other interfaces that will work just fine, but we've tested with the 
above interfaces and can vouch that they work
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MFC Edit Layout and Organization

The MFC-Edit Screen is divided into 8 sections:

1) The Menu Bar – where many of the File and Help related activities are available.

2) The Firmware version and MFC-101 hardware version – only displayed when a SysEx file 
has been imported.

3) These are the 9 “Pages” of MFC-Edit. They are displayed as “Tabs”, analogous to the 
“Tabs” in a spreadsheet program or in a Browser. You click on the Tab related to the MFC-
101 parameters that you want to view or change.

4) The name of the SysEx file being edited – for display only.

5) The name of the Axe-Fx Preset List file currently imported. Blank if none.

6) This is the View/Edit section. Whether you are viewing or changing parameters from 
SONGS, SETS, PRESETS or any of the 9 “Pages”, you will be viewing it or editing it in this 
section only. The contents of this section change depending on which Page you have 
selected for editing. The other un-selected pages are hidden until selected and, in fact, 
disabled until a SysEx dump has been opened.

MFC-Edit is organized like a spreadsheet, with many “worksheets” or “tabs” or “pages” (or whatever 
you want to call them) in order to partition the enormous number of settings, parameters and features 
into logically task-related groups. Additionally, the “pages,” as we'll call them from now on, are 
organized from left to right in their most frequently used order when the MFC-101 is being used to 
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control an Axe-Fx. The IA SWITCHES “page” for editing the MFC-101's Instant Access Switches is first, 
before the PRESETS & EXT.DEVS “page.” See the “page” order in Figure 2 below.

The most commonly used features of the MFC-101 as a companion to the Axe-Fx would be the IA 
SWITCHES, PRESETS, INT.CC & CHANGE MAPS, SONGS & SETS – at least from my 
experience. The “pages” can be selected at will, in any order, with one exception – the initial “page”
when the program first launches. The initial page is the BASE CONFIG page, where global settings
are kept. Furthermore, unless and until a SysEx dump file has been opened for editing, all 
other pages are disabled.

This MFC-Edit Owner's Manual is organized in the same order as the MFC-Edit program because 
that seemed to make the most sense. The first page, as mentioned previously, is the CONFIG 
BASE page and you will see that before you ever get to edit your MFC-101 parameters. The very 
first time ever you launch a new version of MFC-Edit, the release notes will be displayed – read 
them – they are important. 

Presets and PCs and CCs, Oh my!

The power of the MFC-101 presents the user with a plethora of options and loads of flexibility. With
great power, comes great responsibility. (Okay, that was corny). But its true – particularly when the 
device works closely with another device like the Axe-Fx that also has “Presets,” but they're not the
same as the “Presets” in the MFC-101. In order to not be confused (and cut me a break on 
explaining the topic), please read section 4.3 of Fractal Audio Systems's MFC-101 Owner's 
Manual on page 18 before proceeding. You'll be glad you did. In addition, when referring to the 
Axe-Fx “preset” I will use the word “Patch” instead, since they could be considered synonymous in 
the context of the Axe-Fx.

The Menus

See Figure 2 above.

The File Menu

The File menu has the following options:

 Open SysEx File
 Save
 Save As
 Save As Mark I/II/III
 Preferences
 {Recently opened SysEx files}
 Exit

Open SysEx File

Open SysEx File presents you with a file chooser allowing you to navigate to the folder where the 
SysEx dump file you want to load is located. Highlight the file and press the “Open” button. The 
SysEx file that you selected is loaded into MFC-Edit and all the “pages” are populated with that 
data. All of the pages are now “enabled” so that you can select them and edit the content. By 
default this should be the MFC-101/dumps folder, located in your home, Documents or Desktop 
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folder. NOTE:  If the other pages are not enabled then the file load has failed, probably because 
the file is somehow corrupt. You can find additional information on the failure by selecting  the 
“Information, Errors & Support” option off the Help menu. You'll need to figure that out before you 
can use MFC-Edit.

* You must have previously captured the SysEx file from your MFC-101 using MFC-Edit's “Receive
SysEx File from MFC-101” feature off the Tools menu, Fractal Bot, Snoize, MIDI-OX or some other 
such MIDI utility program. Please refer to the MFC-101 Owner's manual for instructions on how to 
do this.

Save

Save silently saves the contents of the MFC-Edit program back into the file that you previously 
loaded. I recommend that you not do this, but instead use the Save As option (below) so that you 
don't overwrite your original file in case you want to go back to it for some reason.

Save As

Save As allows you to choose which folder to save the MFC-Edit session into and what to call that 
file. Once saved, you will transmit that file to the MFC-101 using Fractal Bot, Snoize, MIDI-OX or 
another program of your choice.

Save As Mark I/II -or- Mark III

Save As Mark I/II -or- Mark III is intended for people upgrading from a Mark I/II to a Mark III MFC-
101 controller, or for people who run mixed Mark I/II/III environments. If you have opened a SysEx 
file from a Mark I/II, the option to Save As Mark III appears on the File menu. If you have opened a 
SysEx file from a Mark III, then the option to Save As Mark I/II appears on the File Menu. The 
saved file will be compatible with the hardware version you selected and firmware 3.x.

Import Axe-Fx Presets

Import Axe-Fx Presets enables you to browse for a file previously exported from the Axe-Edit 
program from the Tools->Export As Text->Presets option. Sometimes it is helpful to see the full 15-
character Axe-Fx name of the presets while working in MFC-Edit.

Show Axe-Fx Preset List

Show Axe-Fx Preset List will create a pop-up window with a scrollable list of all 384 Axe-Fx 
preset/patch names (736 for the XL)  and numbers for your reference while working in MFC-Edit.

Preferences

Preferences will present a multi-tabbed window with logically grouped user preferences.  You may 
customize the look and feel and behavior or many of the MFC-Edit functions from this window.

Recently Opened SysEx Files

Recently Opened SysEx Files. Up to four recently opened SysEx file names are displayed in the 
menu for convenience. Selecting one will open it immediately so that you don't' have to go 
navigating around for it.

Exit

Exit will do exactly that – exit the program. However, if you have unsaved edits you are warned 
before the program exits and you are presented the opportunity to save your edits first, or continue 
and lose the edits.
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The Edit Menu

The Edit menu is context sensitive – the options displayed in the Edit menu will depend 
upon which of the Pages (Tabs) is currently displayed.

For example, when the IA SWITCHES page is displayed then the Edit menu has options pertinent 
to the IA Switches and when the PRESETS & EXT.DEV page is displayed the Edit menu will 
contain options relevant to the PRESETS.

Furthermore, the Edit menu contents will differ depending on what is and is not selected on any 
given page. For example, if a Song is selected on the Songs page then there will be additional 
options added to the Edit menu to facilitate movement, copying, pasting, erasing the selected 
song(s) etc.

Lastly, all the options available on the Edit menu are also available from the right-click popup menu
on the pages.  The right-click menu will sometimes have options unavailable from the Edit menu.

The Tools Menu

The Tools menu has the following options:

 Send File to MFC-101
 Receive Dump from MFC-101
 Show Axe-Fx Preset List
 Show Songs Palette
 Show CC Assignments
 Show Virtual MFC-101
 Run Fractal Bot
 Run Axe-Edit
 Hexadecimal Converter
 Convert IA Switches to FW 3.07+
 Get Latest FW SysEx Dumps

Send File to MFC-101

Send File to MFC-101. Select this option when you have a SysEx dump file that you want to 
transmit to the MFC-101 controller. 

Receive Dump from MFC-101

Receive Dump from MFC-101. Use this option when you want to perform an MFC-101 
dump/backup and capture that into a file.

Show Axe-Fx Preset List

This option displays the pop-up list of all your Axe-Fx preset names if you have imported them.

Show Songs Palette

This option displays the pop-up list of all the Songs from the SONGS page of the editor.  You can 
drag these names into the Set slots on the SETS page

Show CC Assignments

This option displays the pop-up list of all the CC (Control Change) message numbers that the Axe-
Fx understands along with the Effect or Action that the CC has.  It is particularly handy when 
setting External Switch CC numbers and Expression Pedal CC numbers.
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Show Virtual MFC-101

Show Virtual MFC-101.  First released in version 6.0 this option will open a new window 
containing the image of the MFC-101.  This image supports “overlays” showing the effect being 
controlled by each IA Switch, the First Preset Switch and the Bank Size is surrounded by a line 
clearly indicating which switches are Preset switches and which control effects.  Pressing the 
REVEAL button reveals which effects are controlled by the Preset Switches when the REVEAL 
switch on the MFC-101 is engaged.  There is a scrolling “palette” of all the Blocks and Controls that
the MFC-101 can control in the Axe-Fx.  Drag a Block from the palette onto the IA Switch that you 
want to assign it to.  Use the First Preset Switch and the Bank Size spin boxes to change the first
preset switch and the bank size respectively.

A number of user preferences can be set for controlling the behavior and appearance of the Virtual 
MFC-101 from the File→Preferences menu option.

Important Notes:  When the Virtual MFC-101 is shown, changes to the First Preset Switch and 
Bank Size on the BASE CONFIG page are immediately reflected on the Virtual MFC-101.  
Likewise, if the Virtual MFC-101 is visible when changes are made on the IA SWITCHES page 
those changes are reflected on the Virtual MFC-101 immediately and vice versa.

Run Fractal Bot

Run Fractal Bot. Conveniently launch the Fractal Bot program from within MFC-Edit.

Run Axe-Edit

Run Axe-Edit. Conveniently launch the Axe-Edit program from within MFC-Edit.

Convert IA Switches to FW 3.07+

If you have a sysex dump from your MFC-101 from a firmware version 3.06 or earlier, when 
upgrading to firmware 3.07 or greater your IA Switches will no longer control the same blocks as 
before.  Selecting this option will convert your IA Switches to map to the correct blocks in 
the new firmware release.

Hexadecimal Converter

Hexadecimal Converter. A convenient popup tool for converting values to/from hex/decimal.
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Get Latest FW SysEx Dumps

Get Latest FW SysEx Dumps. In case you need the “stock” SysEx images to load into your MFC-
101 controller.

The Wizards Menu

The Wizards was introduced in version 4.0 with the following options:

 Expression Pedals
 Bank Style

Expression Pedals

The Expression Pedals wizard is for simplifying the addition and configuration of Expression
Pedals for things like connecting a Wahwah pedal or Volume pedal to your MFC-101 for use 
with the Axe-Fx.  It can be configured on the PRESETS page as well as the GLOBAL XP/XS 
page but this wizard makes it much simpler, providing fewer confusing options.

Bank Style

The Bank Style wizard provides an intuitive way to understand what the Bank Style is and 
how it works, assisting with the selection of the appropriate choice for your needs.

12 Introducing MFC-Edit



The Help Menu

The Help menu has the following options:

 MFC-Edit Owner's Manual
 MFC-101 Owner's Manual
 Axe-Fx As USB/MIDI Interface
 NAME TIMEOUT!  - Get help
 Information, Errors & Support
 Axe-Fx III Addendum
 Check For Update
 Registration Code
 Release Notes
 About MFC-Edit
 Reset Everything

MFC-Edit Owner's Manual

MFC-Edit Owner's Manual is for launching the MFC-Edit Owner's Manual in the system default 
PDF reader.

MFC-101 Owner's Manual

MFC-101 Owner's Manual will launch the system default PDF document reader with the MFC-101
Owner's Manual from Fractal Audio Systems. 
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Axe-Fx As USB/MIDI Interface

Axe-Fx As USB/MIDI Interface will pop up a help window with detailed instructions on how to use 
the Axe-Fx as a USB to MIDI interface for connecting your MFC-101 to the computer. 

AXE-FX NAME TIMEOUT! - Get help

Select this option from the Help menu if you are receiving the dreaded “AXE-FX NAME TIMEOUT!”
message on your MFC-101 when connecting it to the Axe-Fx.

Check For Update

Check For Update. Checks to see if there is a newer version available.

Registration Code

Registration Code pops up a window where you can view and enter the Registration Code that 
you received in an email shortly after purchasing MFC-Edit in the Fractal Audio online store. If you 
haven't received your license key within 24 hours of purchase, please send an email to 
support@fractalaudio.com. You can still run MFC-Edit even without a Registration Code up to 
10 times  before the Registration Code is required.  

Release Notes

Release Notes will pop-up a scrollable, resizable window showing the release notes. It is strongly 
recommended that you read these notes each time you install a new version of MFC-Edit. In fact, 
each time you install a new version of MFC-Edit, you are presented with the release notes window 
the first time you run that version. Take the time to read it so you don't miss out on important new 
features.

Help About

Help About displays some basic information about the purpose and version of MFC-Edit, along 
with your license information.

Reset everything

Reset everything. Use with caution!  Press this button to reset user preferences to the default and
“forget” activity history. MFC-Edit “remembers” certain actions and preferences for you. For 
example, MFC-Edit remembers the page you were on when you last exited the program so that 
next time you run the program, it automatically puts you back there instead of loading the BASE 
CONFIG page by default and forcing you to have to select the desired tab again. If you were on the
PRESETS & EXT. DEVS page when you last exited, it will again place you there upon restart and 
preselect the last PRESET that you were working on. Other information like the last file you 
opened, the last folder you navigated to, etc. are things MFC-Edit will remember for you. Pressing 
the Reset button will make MFC-Edit forget those things.

General Editing Notes

Here are some helpful things to remember while editing your MFC-101 configuration using the 
MFC-Edit program:

 Clicking the left mouse button pretty much anywhere will enter edit mode on the field, 
cell or list being clicked and deselect any previous/current selection, hiding any shown 
previous drop-down list, if visible.

 Clicking the left mouse button will always drop down a list automatically when there is a 
list to make a choice from, or highlight the datum to be edited.
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 Clicking the right mouse button on any field, cell, list, button or checkbox will nearly 
always pop up a “Nugget” of information about the item being clicked. Think of a “Nugget” 
as context-sensitive help, tips, tricks and cautions. 

 In many cases, clicking the right mouse button will pop up a context-sensitive menu with 
power-user options to Show Nugget or perform other operations specific to that screen.

 Clicking any mouse button in the Nugget window will cause it to close. Only one Nugget 
can be open at a time.

 If the amount of text in a Nugget is greater or wider than the Nugget window size a scrollbar
will automatically appear as necessary.

Sending and Receiving SysEx Dumps

One of the first things you will want to do is backup your MFC-101 settings. You can do this from 
the Tools menu of MFC-Edit or by using the Fractal Bot program. If you already have a backup, 
you could skip this section but you might want to read through it anyway since there is additional 
important information.

Receiving a SysEx dump from the MFC-101. From the Tools menu select Receive Dump from 
MFC-101. You will be presented with the following pop-up:

File:  This field is where you can enter the path and name of the file where you want the dump 
saved to. You can use the Browse button to the right to use the navigator to locate a file or folder 
to save it into.

Device:  This pull-down list provides a list of MIDI devices determined to be capable of transmitting
the SysEx dump to MFC-Edit. Choose the device that you are going to use to connect to your 
MFC-101 controller. If you don't see your device, check the connections/power connectivity.
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Open File When Download Complete?:  A convenience so that you don't have to manually 
navigate to wherever you saved the SysEx dump to and open it after the transmission completes.

Cancel:  The cancel button allows you to cancel a SysEx dump capture without waiting for it to 
complete. If there were errors or data loss and you choose not to continue, this would be the way 
to cancel it.

Sending a SysEx dump to the MFC-101:  From the Tools menu, select Send File to MFC-101. 
You will be presented with the following pop-up:

File:  This field is where you can enter the path and name of the file where you want the dump 
saved to. You can use the Browse button to the right to use the navigator to locate a file that you 
want to transmit to the MFC-101. By default, the currently open file is pre-populated for you.

Device:  This pull-down list provides a list of MIDI devices determined to be capable of receiving 
the SysEx dump transmission by MFC-Edit. Choose the device that you are going to use to 
connect to your MFC-101 controller. If you don't see your device check the connections/power 
connectivity.

Manual Delay (ms) Override:  In most cases, MFC-Edit will auto-calculate the delay optimally for 
your system and your interface. Due to the enormous variety of interface/OS/hardware systems, 
MFC-Edit can't always get it right. You should leave this checkbox unselected unless you are 
experiencing reliability issues with transmissions from MFC-Edit to the MFC-101. If you must
set the delay with the slider below, select this checkbox to enable reading of the slider value. 

IMPORTANT NOTE:  If you have been using a USB/MIDI interface with delay auto-detection and 
then you switch to a different USB/MIDI interface, you must press the Delay Help button and from 
the popup window select the Reset AutoDelay button so that MFC-Edit can retrain the delay 
parameters for the new MIDI interface.

Cancel:  Use this option to cancel a transmission without waiting for it to complete. If you do so, 
please remember to cancel the Load on the MFC-101 controller by pressing the ENTER switch (sw
#14) a second time.
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The IA Switches Page

The IA Switches (see Figure 6 below) are one of the most frequently configured/changed 
parameters of the MFC-101. (Ref P.21 MFC-101 Owner's Manual).  The most convenient 
method of configuring your IA Switches for use with the Axe-Fx is by launching the “Virtual 
MFC-101” off the “Tools” menu.  You can simply drag the Axe-Fx Effect Blocks onto the 
desired IA Switch.  Read more in the Virtual MFC-101 section on page 11.  Use the IA 
Switches Page below for more complex configurations.

Figure 5: 

Right-clicking the mouse anywhere on this page will select that row.  Any click in the first column 
(IA#) will also select that row.

IA#. The Switch Number refers to the 17 programmable Instant Access Switches (IA Switches) on 
the MFC-101. You may not change this number.

Name. You can leave the default name of each switch or change it to a name of your own 
choosing to help understand its purpose or assignment. In the example above, I have assigned 
switches 2 and 3 to the Scene Increment and Scene Decrement functions respectively and have 
named the switches SCN INC and SCN DEC. As with most other names in the MFC-101, you are 
restricted to only 7 characters for the name.

Axe-Fx Func. This column is for assigning an Axe-Fx function to the switch numbered on the 
same line. Clicking the mouse in this column will present you with a drop-down list of all the 
available Axe-Fx effects and functions that can be assigned to an IA Switch. Different effects and 
functions are available depending on the MFC-101 model and the Firmware version installed and 
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the drop-down list will only display those appropriate for your device. (Ref. P.22 of the MFC-101 
Owner's Manual). 

NOTE:  If the Virtual MFC-101 window (off the Tools menu) is visible when changes are made to 
Axe-Fx Func. then those changes are immediately reflected on the Virtual MFC-101.

Axe-Fx III Note: When the Axe-Fx mode on the BASE CONFIG page is set to Axe-Fx III then this 
column will prepopulate the CC0 column for the corresponding IA Switch with the CC# 
corresponding to the equivalent block/effect/control of the Axe-Fx II XL+.  Make sure that the Axe-
Fx III MIDI/REMOTE: BYPASS page CC# setting corresponds to this CC#.  Please see the Axe-
Fx III addendum at the end of this document and Page # 118 of the Axe-Fx III Owner’s Manual for 
more information.

Type. The type column lets you specify the type (behavior, actually) of the switch. Clicking this field
will present a drop-down list of choices; they are Toggle, Moment. (momentary) and Off. (Ref. 
P.65 MFC-101 Owner's Manual).

Send w/prst. If “yes,” then this IA Switch's On/Off state are sent each time a Preset is selected. 
Whether the On or Off message is sent with the Preset selection is determined by the IA Switch 
state for a given Preset.

GBL. This column is where you'll specify if the settings you make for this IA Switch will be “Global” 
- meaning that their states will be  retained across MFC-101 preset changes. This causes any 
Saved States (MFC-101 Owner’s Manual section 5.2.3) for the IA Switch to be ignored. After a new
preset is loaded, MIDI messages for the current state of each Global IA Switch are re-transmitted.

Columns c1/c2 CC#s, On/Off, and c1/c2 MIDI Channel and PC Off/On Chan/Val are all selectable 
from their respective drop-down lists. (Ref. P.56 of the MFC-101 Owner's Manual).

Axe-Fx III Note : You must use these columns and MIDI cables to use your MFC-101 with the 
Axe-Fx III.  Just setting the Axe-Fx Func columns isn’t enough. Please see the Axe-Fx III 
addendum at the end of this document for more information.

Custom MIDI Messages. Each IA Switch can transmit an arbitrary MIDI message of any length up
to 16 bytes. Actually, two messages of 16 bytes each. These values are in hexadecimal and 
you'll see that in the drop-down list. The Mesg Len column, however, must be entered in decimal 
notation. (Ref. P.46 and P.77 of the MFC-101 Owner's Manual).
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As with all screens in the MFC-Edit program, clicking the right-mouse button will pop up the Nugget
menu where you can choose to show the Nugget for the screen or item being clicked, or one of the
other operations specific to this screen. Right-clicking on the IA SWITCHES screen will present you
with the following pop-up menu:

 Show Nugget will pop up the Nugget window with information about the items on this 
screen.

 Move Row Down will move the currently selected row down one row. Note that the IA 
Switch Name moves with the row, but not the Number.

 Move Row Up will move the currently selected row up one row. Note that the IA Switch 
Name moves with the row, but not the Number.

 Copy switch # will cause the current switch to be copied to MFC-Edits copy buffer in 
preparation for pasting to one or more other switches.  

 Paste to Switch #(s) - When an IA Switch has been already been copied to the 
clipboard the Paste to Switch # option is also offered so that you can paste the contents
or subset of the contents to one or more selected switches The options are

◦ Paste Everything (except the IA Switch Name)
◦ Paste ONLY the CC columns (Control Change columns)
◦ Paste ONLY the PC columns (Program Change columns)
◦ Paste ONLY the MIDI Message columns

 Cancel will do nothing but close the pop-upu.

The Edit menu contains the same options as the pop-up menu.
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The PRESETS and EXT. DEVS Page

This page is for configuring Preset-specific information. You can set the name of a preset and 
many other parameters. 

Please see Figure 8 above and note the layout of this page. In the upper left corner, there is a 
drop-down list where you will select the preset that you wish to configure. The name is 
automatically displayed next to the number. The list of numbers will be in the range of 0-383 or 1-
384 for Axe-Fx I/II and 0-735 or 1-736 for the Axe-Fx II XL depending on the value of your “Display 
Offset” on the BASE CONFIG page.

Right-clicking the mouse on the Preset Name field, Program Change table or MIDI Message table 
below will present you with powerful editing options for the Name, Program Change and Custom 
MIDI Messages

Tooltips are present for most of the elements on this page simply by hovering over that element.

MFC-101 Preset Number:  Select the preset from the drop-down list and all the information 
regarding its name, Alternate Preset, External Switch configuration, External Pedals, initial IA 
Switch States (on/off), initial Internal CC states (on/off), Program Change settings (0-999) and a 
Custom MIDI Message are displayed. If you have imported the Axe-Fx Preset List created by Axe-
Edit then that name is also displayed below the Alternate Preset setting. 

The Spin-box can be used in addition to the drop-down list to select a preset number. You can also 
directly enter a preset number into the Spin-box editor field.
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Preset Name:  You may change the name of the MFC-101 preset here. The preset name here is 
one of the few places where a name you choose can be longer than 7 characters. This preset 
name can be up to 15 characters long. You can drag/drop names/text into the Preset Name field, 
especially useful from the Axe-Fx PRESET field to the right. TIP: Right-clicking the mouse will 
display the power-tools options for mass-population from the Axe-Fx Preset names.

NOTE:  The name displayed beside the “Axe-Fx PRESET” label will almost certainly be different 
from the MFC-101 preset name. MFC-Edit looks at the “Axe-Fx Preset Transmit Map” table on
the INT.CC & CHANGE MAPS page and uses this information to map to the correct Axe-Fx 
patch number and name.

Copy / Paste:  The Copy/Paste button allows you to “clone” the currently selected Preset to 
another Preset number or multiple Preset numbers. From the popup window where you select your
target Presets you can also select which elements of the Preset you want pasted, or you can check
the “Paste All” checkbox to paste everything. If the “Name” checkbox is selected then the name of 
the target Preset(s) will be the same as the source Preset with a prefix of “+” prepended, otherwise
the target preset name is unchanged. You can select more than one target preset. Pressing the 
“Copy/Paste” button will pop up a Palette of all Presets for you to select from. NOTE: While the 
Presets Palette is visible, you cannot change the selected source Preset. See Figure 9 below.

Tip: If you have a great number of Presets that you want to paste parameters to it might be easier 
to press the “Select All Presets” button and then explicitly deselect those Presets that you do not 
want to paste the parameters to.  The “source” preset that you are copying from is always 
deselected.

Global Preset:  This drop-down list allows you to set your Global Preset. See Section 4.5.1 of the 
MFC-101 Owner's Manual for more information. The name of the Axe-Fx Patch that the Global 
Preset currently points to is displayed to the right of the Preset. If no Axe-Fx Preset List has been 
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imported then the name field is blank. NOTE:  The last two options at the bottom of this list are 
“Off” and “Back” respectively. “Off” means there is no Alternate Preset and “Back” means switch 
back to the Preset that was selected before the current one when the MFC-101 is in use.

ALT Preset:  Clicking in the second column, to the right of the ALT PRESET label will enable you 
to select the Alternate Preset for the currently selected preset. Your choices are a preset number, 
“Off”, “Glob” or “Back”. “Glob” tells your MFC-101 to use the preset defined as “Global” (see Global
Preset on the BASE CONFIG page) and “Back” tells your MFC-101 to select the last preset that 
was selected before this one. You cannot change the name of the Alternate Preset here, only 
assign it as the alternate to the preset that has been selected from the drop-down list in the upper 
left corner of this page. If you want to change the name of the ALT PRESET, select it for editing 
from the drop-down list in the upper left corner first. (Ref. P.44 of the MFC-101 Owner's Manual).

Axe-Fx Preset:  If you have imported an Axe-Fx Preset List that was created by the Axe-Edit 
program from Fractal Audio Systems (and we encourage you to do so), then the number of the 
Axe-Fx patch and the name that correspond are displayed here. 

IMPORTANT NOTE:  Furthermore, the Axe-Fx patch that is displayed below the ALT PRESET is 
mapped:  when Axe-Fx Mode is set to NONE on the BASE CONFIG page, then the Program 
Change map of each Preset is used to determine which Axe-Fx patch is selected. When in any of 
the Axe-Fx modes (FX, Ultra, FX II or FX XL) is selected then the Axe-Fx Preset Transmit Map (on 
the INT. CC & CHANGE MAPS page) is used to determine the target Axe-Fx patch. In short, the 
User Interface follows the behavior of the MFC-101 firmware. This Axe-Fx Preset number can be 
changed by clicking the number – it will automatically be reflected in the Axe-Fx Preset Transmit 
Map.  This is handy of you want a given MFC-101 Preset to select an Axe-Fx Preset in the range of
834 – 999.

Axe-Fx III Note: When the Axe-Fx Mode on the BASE CONFIG page is set to Axe-Fx III then make
sure to choose the CC# that you have set in the MIDI/REMOTE menu of the Axe-Fx III.  This is 
necessary for both the PER-PRESET EXTERNAL SWITCHES and PER-PRESET EXPRESSION 
PEDALS. Please see the Axe-Fx III addendum at the end of this document for more information.

PER-PRESET EXTERNAL SWITCHES:  Here you will configure the switch type, the MIDI 
Channel to transmit on, the Control Change number (or Axe-Fx effect) and the On and Off values 
for each of the four external switches on the MFC-101. (Ref. P.17 – PRESETS & PRESET MODE 
of the MFC-101 Owner's Manual).  If you do not set these values then the default value will be the 
same as you have the external switches configured on the GLOBAL XP/XS page. Conversely, 
setting values here will override the global settings.  Note: When scrolling through or selecting the 
CC# (Control Change) in the drop-down list the tooltip will show the name of the corresponding 
Axe-Fx effect block (assuming that the MIDI Channel selected is that of the Axe-Fx).

PER-PRESET EXPRESSION PEDALS:  Here you will configure the four external Expression 
Pedals of your MFC-101. You can set the Channel, the CC number, the beginning value of the 
pedal when this preset is selected and the minimum and maximum values transmitted by the 
pedal. See Pedal Calibration in the MFC-101 Owner's Manual for more information. (Ref. P.17 – 
PRESETS & PRESET MODE of the MFC-101 Owner's Manual).   If you do not set these values 
then the default value will be however you have the external expression pedals configured on the 
GLOBAL XP/XS page. Conversely, setting values here will override the global settings.

Instant Access Switches initial state:  When you switch to an MFC-101 preset you will want to 
know the initial state of each of the IA Switches. For example, if you have IA Switch #1 assigned to 
DRIVE1, when you switch to a particular preset, do you want DRIVE1 on (and the LED glowing 
green) by default? If not, and you only want DRIVE to engage when you press IA Switch #1, then 
you would set this initial state to “Off,” denoted on the PRESETS & EXT DEVS page by the 
corresponding push-button being “out/up” and the LED showing red color. If a switch is “On,” or 
depressed by default, then it will show the green LED. (Ref. P.26, P.45 of the MFC-101 Owner's 
Manual). Tip:  Hover the mouse over the IASwitch to see the switch name and which effect is 
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assigned to it in this patch. NOTE:  The On/Off state message is sent to the Axe-Fx only if the 
“Send w/prst” column on the corresponding IA Switch of the IA SWITCHES page is set to 
“yes.”  The Axe-Fx usually remembers the default effect block settings without the help of the 
MFC-101 so under “normal” circumstances you don't have to send the switch states with each 
Preset selection.  Hint: If you hover the mouse pointer over the IA Switch button, a tooltip will 
display the effect that this IA Switch controls.

Internal CCs initial state:  Ditto for the INT CC states. See the MFC-101 Owner's Manual for 
more information in the INT CCs. (Ref. P.26, P.45 of the MFC-101 Owner's Manual).  Hint: If you 
hover the mouse pointer over the INT CC button the name of that Internal CC will be displayed in a
tooltip.

Program Change:  When an MFC-101 Preset is selected, a Program Change message is sent for 
each of the 16 MIDI channels. The default PC number sent is the same as the MFC-101's Preset 
number, but you are at liberty to set them to any valid PC number between 0 - 999. There is a 
“magic” PC number at the very end of the drop-down list, called “None,” which when chosen will 
cause nothing to be sent on that MIDI channel when the preset is selected. Here is where you will 
set those Program Change numbers to send. (Ref. P.26, P.44 of the MFC-101 Owner's Manual). 

NOTE: The AxeFx PC Transmit Map from the INT.CC & CCHANGE MAPS page will override the 
actual PC sent to the Axe-Fx but all other MIDI devices will be sent the value from this table on the 
MIDI Channel designated.

Right-clicking the mouse on the Program Change table or MFC-101 Preset Name will pop up 
a menu of power-user operations on the PCs and Preset Name. You can perform some powerful 
options from this menu, so use it with caution!  You can

 Show Nugget
 Clone Axe-Fx Preset Name – THIS Preset
 Clone Axe-Fx Preset Names – ALL Presets
 Clome Axe-Fx Preset Names – DEFAULT MFC names
 Clear all PCs – ALL Presets
 Clear all PCs – THIS Preset only
 Clear all except user-input PCs
 Clear all except Axe-Fx channel PCs – ALL Presets
 Paste MIDI message from clipboard
 Cancel

Show Nugget – display the Nugget for this item

Clone Axe-Fx Preset Name – THIS Preset – this option will replace the current MFC-101 Preset 
Name with the name of the Axe-Fx Preset (that you imported from the Axe-Fx via the Axe-Edit 
program).  Remember, Axe-Fx Presets numbers and MFC-101 Preset numbers do not necessarily 
have a direct correlation. 

Clone Axe-Fx Preset Names – ALL Presets – this option will replace all MFC-101 Preset names 
with the corresponding Axe-Fx Preset names that you imported.

Clone Axe-Fx Preset Names – DEFAULT MFC names – this option is much like the previous 
option in that it  will replace all MFC-101 Preset names with the corresponding Axe-Fx Preset 
names that you imported except if the MFC-101 Preset name has already been changed by you. 
This is to preserve any manual changes that you may have already made.

Clear all PCs - ALL Presets – this option will set the PC for every MIDI Channel for every MFC-
101 Preset to “None.” The Axe-Fx PC is still sent to the Axe-Fx regardless. You are prompted to 
confirm this operation before it is executed.

Clear all PCs - THIS Preset – sets the 16 MIDI Channel PCs for this preset to “None.”
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Clear all except user-input PCs – sets all the PCs for all Presets to “None” except for those that 
differ from the “default” of the Preset Number on each of the 16 MIDI Channels.

Clear all except Axe-Fx channel PCs – ALL Presets – This will set all MIDI channel PCs to “off” 
except the PCs on the Axe-Fx MIDI channel

Paste MIDI message from clipboard – This is a quick way to paste hexadecimal message bytes 
into the Custom Midi Message fields.  As long as the values copied to the clipboard are space-
separated hexadecimals values this is quicker than entering the values one by one.

Cancel – closes the popup menu without performing any operation at all.

Custom MIDI Message:  The MFC-101 can send an arbitrary MIDI command sequence upon 
being selected. You can enter up to 16 hexadecimal bytes to send. NOTE:  The message length is 
automatically calculated but check it! Do not include any trailing zeroes in the message length. 
(Ref. Section 12.1.6  of the MFC-101 Owner's Manual). The hexadecimal values can either be 
directly entered from the keyboard, selected from the drop-down list (see the PRESETS tab of the 
Preferences window) or pasted from the system clipboard by right-clicking the mouse over the 
MIDI message and choosing the “Paste MIDI message from clipboard” option.

As with all screens in the MFC-Edit program, clicking the right-mouse button will pop up the 
“Nugget” for the item located where the mouse cursor is. In some cases, the Nugget contains 
information for the whole page and in other cases, it might pop up a context-sensitive menu 
allowing you to choose to either display the Nugget or perform other operations specific to the item 
that was clicked.

INT CC and CHANGE MAPS

The INT. CC & CHANGE MAPS page has three sections; the “Internal Control Change” section on
the left, the “Program Change Map” in the upper right quadrant and the “Axe-Fx Preset Transmit 
Map” in the lower right quadrant. Each has a specific purpose. See Figure 9 below. (Ref. P.30 and 
P.54 of the MFC-101 Owner's Manual).
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Internal Control Change

The Internal Control Change section has the following columns:  (Ref. P.58 of the MFC-101 
Owner's Manual).

Control Change Number
Control Change Number:  The left-most column is the Internal Control Change number, 1-
17. This number cannot be changed.

NAME
The NAME column holds a default name for the Internal CC. You can edit this name by 
selecting the cell with the mouse cursor and typing in a new name. As usual, you are limited
to a maximum of 7 characters.

Chan
The Chan column allows you to select the MIDI channel of 1-16.

CC#
The CC# column is where you would select which CC# would be sent. Click the mouse in 
that column and choose the CC#  from the drop-down list. The last “CC#” in the list is the 
“magic” word “Off.” If you choose “Off,” then no Control Change message will be sent on 
this MIDI channel. 

Off / On
The OFF and ON columns are where you would set the Off and On values respectively. 
Clicking in these columns, you are presented with a drop-down list of values to choose.

Inbound Program Change Map

Inbound Program Change Map:  (Ref. P.54 of the MFC-101 Owner's Manual). This 
section consists of two elements; a drop-down list of numbers and a row of 16 cells for 
setting the value you desire. The MFC-101 has 384 mappings for the Program Change 
messages and placing them all on a page at the same time would create a confusing, 
cluttered and very error-prone experience for the user. That's where the drop-down list 
comes in. In order to make this vast array of parameters manageable, we have divided the 
PC Maps in to banks of 16; 0-15, 16-31, … and so on through 383. If you want to change, 
for example, PC Map 86 (when you choose preset 86, map it to the value you input into the 
cell numbered 86 in the column header) then click on the drop-down list and choose the 
“bank” identified as “80-95” because the number 86 is within this range. Selecting that 
range will change the column headers of this bank and you can now change the value of 
the PC number in the column labeled “86.”   Don't make changes here unless you know 
what you're doing and you really need to do so.

Axe-Fx Preset Transmit Map

Axe-Fx Preset Transmit Map:  Changing values for the mapping of PC numbers to 
transmit a different PC number when the preset is selected on the MFC-101. Edit these 
values the same as described above for the Program Change Map. When your MFC-101 is
operating in Axe-Fx mode, this field will map the PC number sent to the Axe-Fx.  Note for 
Axe-Fx II XL users: you can use this map to have an MFC-101 Preset numbered 0-383
select a patch number greater than 383 on the Axe-Fx II XL.  For example, you might 
map your MFC-101 Preset number 221 to select patch 564 on the Axe-Fx II XL.

As with all screens in the MFC-Edit program, clicking the right-mouse button will pop up the 
“Nugget” for the item located where the mouse cursor is. In some cases, the Nugget contains 
information for the whole page and in other cases, it might pop up a context-sensitive menu 
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allowing you to choose to either display the Nugget or perform other operations specific to the item
that was clicked.

The SONGS Page

On the SONGS page is where you'll enter up to 100 songs, the current limit of the MFC-101. (Ref. 
P.37 of the MFC-101 Owner's Manual). In the first column is the Song number, which you cannot 
change. The second column, labeled “Name” is where you will enter the name of a song that you 
will perform. You can give it any name you want, but since the MFC-101 allows you a maximum of 
7 letters or numbers I suggest you don't use spaces or punctuation. You'll try to invent meaningful 
abbreviations so that you know which song it actually refers to. For example, if you perform a tune 
called “Gimme Three Steps,” you might enter the abbreviation of “Gimme3,” or if you are selecting 
a preset for “Long Train Running” you might enter “LongTrn.” It's up to you. 

Columns labeled 1-15 are the actual Axe-Fx Patch numbers that will be selected when you use the
MFC-101 song slot. So for example, if I have “Bad Love” in the slot #15 of the SONGS page, and a
number '10' in the column labeled 'P01' (see Figure 3 below) then when I select SONG #15 on the 
MFC-101 (from the SETS, SONG performance modes – more on that later) then the MFC-101 will 
command the Axe-Fx to switch to Patch #10 (by sending it a Program Change message). Note that
the Display Offset setting on the BASE CONFIG page should match the Display Offset on the Axe-
Fx or you might get the patch before or after the one you expected switched to. You can find more 
information on this topic in section 12.5.2/3 of the MFC-101 Owner's Manual. The MFC-101 will 
always display the number of its own Preset and never the number of the Axe-Fx or other 
connected MIDI equipment.
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The Song Name column can accept Copy/Past operations and you can also Drag/Drop names 
onto a cell in this list. If you drop a name longer than 7 characters, it will be automatically 
truncated.  

When clicking the mouse in one of the preset cells (each song can have up to 15 Presets assigned
to it), you will be presented with a drop-down list of Preset numbers to choose from. The Preset 
number range will be either 0-383 or 1-384, depending on what your “Display Offset” value is set to
(see “BASE CONFIG” page 26). NOTE: These are MFC-101 Preset numbers that you are 
entering here.  If you have previously imported an Axe-Fx Preset List (created by the Axe-Edit 
software, see P.9 this document), then hovering the mouse over a Preset number cell will show the
corresponding Axe-Fx patch name in that location. It is not always accurate, but its a helper 
sometimes. If you have the “Popup Axe-Fx Preset List on SONGS tab?” selected in the 
Preferences then a window will pop up, showing a list of all the Axe-Fx patch names. From this 
popup list, you can select the patch by name instead of number.  Remember: this is only a 
convenience if your MFC-101 Preset numbers correspond 1-to-1 with your Axe-Fx Patch numbers.

If you have not imported the Axe-Fx Preset List (exported from the Axe-Edit program), then 
hovering the mouse over a patch number will just show the word “None” and the Axe-Fx Preset List
popup will be empty.

Clicking the mouse cursor on the column header will cause the table rows to be sorted in 
ascending order of the values in that column. Clicking that column header a second time will result 
in the rows being sorted in descending order. Sometimes its useful to sort alphabetically when 
entering songs. Sorting does not change the numerical order of the songs – the song numbers 
(left-most column) travel with the song.

As with all screens in the MFC-Edit program, clicking the right-mouse button will pop up a context-
sensitive menu that will allow you to view the “Nugget” for the item located where the mouse cursor
is and perform operations specific the item that was clicked. The SONGS popup menu allows you 
to select:

 Show Nugget
 Show Axe-Fx Preset List
 Show/Hide Name Columns

◦ Hide MFC name column
◦ Hide Friendly name column
◦ Show MFC name column
◦ Show Friendly name column

 Suggest MFC short names
◦ Suggest MFC name for current friendly name
◦ Suggest MFC name for “default” names
◦ Suggest MFC name for all friendly names

 Clear Song “Song Name”
 Clear All Songs!
 Insert Song and Renumber!
 Delete Song and Renumber!
 Renumber All – CAUTION!
 Move Song Up and Renumber!
 Move Song Down and Renumber!
 Copy Selected Song
 Paste Selected Song
 Cancel

IMPORTANT NOTE: The menu items in red, with an exclamation at the end, should be used with 
great caution. If you are using the SETS or Set List features of the MFC-101 performing any 
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operation that changes the numbering of your songs will invalidate your Set Lists.  There is no 
“undo” operation for this ;-). If you hose it up and want to restore it to its previous state, you 
must reload the file from disk.

NOTE:  The last and final preset “number” in the drop-down list that you can choose is the word 
“None”. Choose this “patch” from the list in order to clear a preset cell of any preset number.

Friendly Song Names.
The MFC-101 allows you to have song names of up to 7 characters only. When abbreviating the 
song names to just 7-characters that fit into the LCD display on the MFC-101 they can be difficult 
to understand.  Selecting Show Friendly Song names instead? on the SONGS & SETS page of 
the Preferences window will allow you to work with the 25-character “Friendly Name” everywhere 
you would normally use the 7-character MFC-101 Song name.  You cannot view the 25-character 
friendly name on the MFC-101 due to the size limitation of the LCD display.

You can sort the songs on the SONGS page by clicking the column header for the Song #, the 
Friendly Name or the MFC Name.

To see these friendly names instead of the actual MFC-101 song names the “Show Friendly Song 
Names Instead?” checkbox in the Preferences popup must be selected.  On the SONGS page, if 
the friendly name is too long to fit in the cell, hover the mouse over the name both the MFC-101 
song name and entire friendly name will be displayed. 

Axe-Fx II XL – Special Note!

The MFC-101 has only 384 Presets but the Axe-Fx II XL has 834 Patches. The recommended way 
to access the Axe-Fx Patches that have numbers higher than 384 is to use Axe-Manage or Axe-
Edit to relocated the desired Axe-Fx Patches to a lower number.  Alternatively, to access the Axe-
Fx Patches above 384 (or 383 if your Display Offset is set to 0) you can select a different Axe-Fx 
Patch number on the PRESETS & EXT.DEVS  page or you can use the Axe-Fx Preset Transmit 
Map on the INT. CC & CHANGE MAPS Page of the MFC-Edit program.

The SETS Page

The SETS feature of the MFC-101 provides you with up to 10 different “Sets” of “Songs” from the 
the SONGS page. I use the SETS feature to create “Set Lists” for the different venues at which I 
perform. (Ref. Section 9.1 of the MFC-101 Owner's Manual). The first column is pre-populated with
the “slot” number. You may not change the slot number. The remaining columns are the 10 Sets, 
each with up to 50 Songs from the SONGS page discussed above. 

Entire rows cannot be selected on the SETS page because that would make no sense at all.
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Set Name

Each Set in the MFC-101 can be named. Like most names in the MFC-101, you have a maximum 
of 7 characters (letters or numbers) to create a meaningful abbreviation for the Set Name. You can 
see the name of each of the 10 sets in the column header of each column on the SETS page. To 
set or change the Set Name, you must double-click on the column-header of the Set that you wish 
to change. You can edit that name in place. Pressing Enter/Return or clicking in another location 
saves your edits to that Set Name.

NOTE:  SETS can be dragged and dropped to change the position of the entire SET by clicking on 
the SET Name and dragging it to another SET position.  When a SET is dropped onto another 
location the two SETS swap positions – the sets are not all shifted left or right.

Slot

The left-most column on this page is the “slot” number in the Set of each song. They are labeled 
“Sng01,” Sng02,” etc. and cannot be changed since they are labels only.

Set Song

Each Set can contain up to 50 songs from the SONGS page. By clicking the mouse in one of the 
50 slots under the Set you are creating/changing, a drop-down list of all the songs from the 
SONGS page is displayed. You can scroll up or down using the mouse to select the song that you 
want in that position. There is a “magic” song name in the very first position of the drop-down 
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Songs list, “-Empty-,” which you can select to clear out a slot so that no song at all is specified in 
that position of that Set.  Alternatively, you can right-click the mouse and from the context-sensitive 
menu select “Popup Song Palette.” From the Song Palette, you can drag and drop Songs into your
Sets. If you have created a Friendly Song Names map and enabled showing of the Friendly Names
in the Preferences popup, hovering the mouse over a given slot will display the friendly name for 
that song.  If you have selected the Show Friendly Song Name Instead? in the Preferences 
popup then the 25-character Friendly Name is displayed in the cells and the drop-down list instead 
of the 7-character MFC-101 song name.

Interactive Editing Aids

 Double-click on the column header where the SET name is to change the SET name.
 Click and hold the mouse button on the column header and then drag the SET (column) to 

another location.
 You can drag and drop SONGS from one location to another. 
 Important note: 

◦ when dragging a SONG from one location into another location within the same SET, 
the SONG is simply relocated.

◦ When dragging a SONG from one SET into another SET the “source” SONG is 
unchanged but the “destination” SONG where you drop it is replaced.

Power tools menu
As with all screens in the MFC-Edit program, clicking the right-mouse button will pop up the 
Nugget menu whereupon you can choose to show the Nugget for the screen or item being 
clicked, or one of the other operations specific to this screen. Right-clicking on the SETS screen 
will present you with the following pop-up menu:
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Show Nugget
Show Nugget will pop up the Nugget window with information about the items on this 
screen.

Popup Song Palette

Popup Song Palette will popup another window containing a “palette” of all the songs from 
the SONGS page. These songs can be dragged and dropped onto slots on the SETS table.
They are sorted in alphabetical order on the palette to make finding them easier.

Insert Song – shuffle down

Insert Song will insert a blank cell at the row and column that the mouse cursor was 
clicked. All the songs below the inserted cell are shuffled down one position and the final 
cell at the end (cell number 50) is discarded.
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Delete Song – shuffle up

Delete Song will delete the cell at the row and column that the mouse cursor was clicked. 
All the songs below the deleted cell are shuffled up one position and the final cell (cell 
number 50) is set to empty.

Sort Set

Empty To End will sort the songs (in the selected set only) in alphabetical order and move 
all empty song slots to the end of the list.

Invert Set

Top to bottom will invert the currently selected Set, moving the first Song to the last Song 
in the Set and vice versa, the second Song to the second-last Song position and so on.

Move Set Left

Move Set Left moves the entire set to the left one position, effectively exchanging it with 
the set that was in that position.

Move Set Right

Move Set Right moves the entire set to the right one position, effectively exchanging it with
the set that was in that position.

Copy Set

Copy Set will copy the currently selected set to a “copy buffer” for subsequent pasting.

Paste Set

Paste Set only appears in the menu when a Set is present in the copy buffer from a prior 
Copy Set operation. Selecting this option will paste the Set on top of the selected Set, 
overwriting it.
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The MIDI & CHANS Page

This page is for setting values for the MIDI Channels and other general purpose MIDI settings. 
MIDI Channel Configurations.

The MIDI Channel Configurations enable you to change the Display Offset for each MIDI channel
and to change its name. The maximum length of a channel name is 7 characters.

Other MIDI Settings

The Other MIDI Settings is where some miscellaneous MIDI parameters can be viewed and 
changed.

Axe-Fx MIDI Chan

Axe-Fx MIDI Chan is the MIDI channel on which the MFC-101 will transmit its CC and PC 
commands to the Axe-Fx. This must be the same MIDI channel as that set in the Axe-Fx. (Ref. 
Section 9.3 of the Axe-Fx Owner's Manual).

Axe-Fx Display Offset

Axe-Fx Display Offset is the Display Offset value setting in the Axe-Fx. Changing this does not 
change the setting in the Axe-Fx but it does tell the MFC-Edit program how to map the display of 
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MIDI channels to the presentation in this program. For example, MIDI channels start at zero and 
end at 15 according to the MIDI specification but most people want to see values that start at 1 and
continue through 15. Likewise the preset numbers begin with 0 and end with 383 (for all but the 
Axe-Fx XL) but most people want to see Presets numbered 1-384. If the value set here does not 
match the value set in your Axe-Fx equipment then the preset numbers/names will be off by 1 
when displayed.

MIDI Receive Channel

This is the MIDI channel that the MFC-101 listens to for incoming PC commands, if enabled. The 
channels are 1-16 if responding to incoming Program Change commands or the last “channel” in 
the drop-down list of “Off” to select no channel.

Receive Program Change

Receive Program Change tells the MFC-101 whether or not to respond to Program Change 
requests received on the channel specified above. (Ref. P.54 of the MFC-101 Owner's Manual).

Use Port

Use Port is the port that the MFC-101 had active at the time the SysEx file was captured. It is a 
runtime parameter and changing it will likely be overridden by the MFC-101 equipment. The 
choices for this value are MIDI (the two 7-pin din connectors for the MIDI-in and MIDI-out on the 
back of the MFC-101), Expansion (the Ethercon connector) or in the case of the MFC-101 MDIII, 
FASLINK.

Axe-Fx III Note: When the Axe-Fx mode on the BASE CONFIG page is set to Axe-Fx III then this 
parameter is automatically set to MIDI since this is the only way to connect an MFC-101 to the 
Axe-Fx III.  Please see the Axe-Fx III addendum at the end of this document for more information.

As with all screens in the MFC-Edit program, clicking the right-mouse button will pop up the 
“Nugget” for the item located where the mouse cursor is. In some cases, the Nugget contains 
information for the whole page and in other cases, it might popup a context-sensitive menu 
allowing you to choose to either display the Nugget or perform other operations specific to the item 
that was clicked.
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The GLOBAL XP/XS Page

The Global Expression Pedal and External Switch page is for setting the all the parameters for the 
two Expressions Pedals and four External Switches that will be global, across all Presets. Here you
can also set the Expression Pedal calibration and the External Switch hardware types.

Figure 13: 

Global External Switches

See Section 8 of the MFC-101 Owner's Manual.

 Type – Can be Hardware, Toggle or Auto Off. 

 Chan. - The MIDI channel that this Switch will send its messages on.

 CC# - The CC# that this Switch will send when activated by depressing the switch.

 Off and On – These are the On and Off values respectively that this switch will send. 

Global Expression Pedals

See Section 8 of the MFC-101 Owner's Manual.

▪ Chan. -  The MIDI channel that this Pedal will transmit its messages on.

▪ CC# - The CC# that this Pedal will send with its values.

▪ Beg. - This is the beginning value of the Pedal, before you move it.

▪ Min. and Max. - The Minimum and Maximum values that this Pedal will send.
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External Switch Hardware Types

Select the hardware type of each of your four external switches. They can be either “Momentary” 
or “Toggle.” See Section 8.1 of the MFC-101 Owner's Manual for more information.

Expression Pedal Calibration

While you can change the Minimum and Maximum values of each of your Pedals here you should 
probably not do so. These values are determined by performing the Calibration sequence 
described in the MFC-101 Owner's Manual. See Section 7 of the MFC-101 Owner's Manual for 
more information.

Axe-Fx III Note: You must ensure that you set the same CC#s here that are also set in your Axe-Fx
III under the SETUP menu.  Please see the Axe-Fx III addendum at the end of this 
document and Chapter 12 of the Axe-Fx III Owner’s Manual for more information.
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The BASE CONFIG Page

 Last, but by no means least, is the BASE CONFIG page where some very important basic settings
are configured. Here is where you will view and set the MFC-101 Modes, Operating Modes, 
Display Offset, Display Contrast and many other parameters. MFC-101 Modes

Axe-Fx Mode
The choices in this drop-down list are None, Axe-Fx, Axe-Fx Ultra, Axe-Fx II,  Axe-Fx XL and Axe-
Fx III. If you are using your MFC-101 as a companion controller to an Axe-Fx model from Fractal 
Audio Systems, then select the appropriate model here. If you are not using your MFC-101 with an 
Axe-Fx model, or don't want any of the factory preconfigured companion settings in effect and 
prefer to program everything yourself, then select the “None” option here.

Axe-Fx III Note: When Axe-Fx III is selected the “Port” used by the MFC-101 is set to MIDI so don’t
expect to use the Ethercon/Expansion or FASLINK connections. Only MIDI cables and 
connection between the MFC-101 and the Axe-Fx III is supported.  When Axe-Fx III is selected
the Axe-Fx Mode is essentially equivalent to “None” except for the setting of the MIDI port and the 
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Axe-Fx Func column on the IA SWITCHES page automatically setting the CC# for effect blocks 
bypass in the CC0 column for you.  Please see the Axe-Fx III addendum at the end of this 
document for more information.

Performance Mode
The choices in this drop-down list are Preset, Song or a Set Number. If you have named your sets 
then the Set Name will appear here. (Ref. P.61 of the MFC-101 Owner's Manual).

MFC-101 Display Offset

The MFC-101 display offset is reflected in the display of preset and MIDI channel numbers. (Ref. 
P.61 of the MFC-101 Owner's Manual).

Display Contrast

This controls the contrast of the LCD display on the MFC-101. Set it to your liking.

Other

Looper Control
The choices are Off, Long or Short. This defines whether the Looper will be activated by a Short or 
Long press of the Looper Switch. Off means that the Looper footswitch will not activate the Looper 
function at all. (Ref. P.70 of the MFC-101 Owner's Manual).

Edit Switch Mode
The choices are Short or Long indicating whether the EDIT/SAVE button will be activated by a 
Short button-press or a Long button-press. Sometimes its safer to set it to Long so that in the event
that you strike it by mistake during a performance your MFC-101 will not enter Edit mode and mar 
your otherwise scintillating performance.

Axe-Fx IA Off LED
This defines the appearance of the LED indicator on each of the IA Switches when in Axe-Fx 
mode. Your choices are RED or OFF. When the switch is “On” the LED is always green. When the 
switch is off you can either have the LED illuminated RED or not illuminated at all (OFF). The 
default in Axe-Fx mode is for all presets is by default GREEN=On, RED=Off, NOT ILLUMINATED 
means that this switch is not configured for this preset. (Ref. P.12,23 and 69 of the MFC-101 
Owner's Manual).

Tuner On Tempo
The choices are On or Off indicating whether a long press (2 seconds) on the TAP TEMPO 
footswitch will activate the Tuner or not. (Ref. P.69 of the MFC-101 Owner's Manual).

Banks

View
This oversized square button will pop up the Visuam MFC-101 window, showing the image of your 
MFC-101 and the layout of your First Preset Switch and Bank Size (see below).  Changes made to
the First Preset Switch and the Bank Size are immediately reflected in the Virtual MFC-101 
window.  See more information on this feature under Tools→Show Virtual MFC-101.
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First Preset Switch
Available on the MFC-101 Mark III with Firmware 3.6 and greater only – This feature allows you to 
start your IA Switches before your Preset switches. You could start your Preset switches at Switch 
#11 for example, leaving your switches 1-10 for IA purposes.

Bank Size
The MFC-101 Bank size can be between 0 and 17. (Ref. P.17 of the MFC-101 Owner's Manual).

Bank Style
The choices are None, Current or First Location. This setting determines which preset (within the 
bank) will be selected immediately upon switching banks. (Ref. P.18 of the MFC-101 Owner's 
Manual).

Current Bank
The bank that was selected at the time of the SysEx dump capture.

Bank Limit
Used to prevent access to banks or songs greater than this number. (Ref. P.64 of the MFC-101 
Owner's Manual).Bank Wrap

The choices are Off and Wrap determining if, upon reaching the last bank the next press of UP will
wrap around to the beginning of the list of Banks (or Songs) or stop.

IA Switch Links

The Instant Access switches can be grouped into up to two groups of five switches each. These 
five switches can be linked to make the mutually exclusive. (Ref. P.66 of the MFC-101 Owner's 
Manual). You will use these drop-down lists to select the IA Switches that you want to group 
together for exclusive access.

Tx Switch Link Off Message
Checking this box will cause the MFC-101 to transmit the CC “Off” sequence for each of the 
switches in a link group in the “Off” state when one switch is pressed “On.” (Ref. P.67 of the MFC-
101 Owner's Manual).

As with all screens in the MFC-Edit program, clicking the right-mouse button will pop up the 
“Nugget” for the item located where the mouse cursor is. In some cases, the Nugget contains 
information for the whole page and in other cases, it might pop up a context-sensitive menu 
allowing you to choose to either display the Nugget or perform other operations specific to the item 
that was clicked.

Preferences – off the File menu

Figure 15: 

There are many ways to alter the behavior of the MFC-Edit program to better suit your personal 
preferences.  Select the Preferences option from the File menu to pop up the Preferences window
above where you can customize your MFC-Edit experience.  Most of these options were previously
present on the EXTRAS page, which was deprecated in MFC-Edit version 5.0.
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GENERAL tab

Visual Theme
There are three different themes, or “looks” for MFC-Edit. The “Fractal” theme (the default) 
uses the same fonts and color scheme as other Fractal products.  The “MFC-Edit” theme is a 
light gray background but the same 3D look and feel to the visual elements. The “Metal” theme 
is a more “sterile” 2D look made popular by many Java language applications.

Show window decorations
Fractal Audio Systems' programs (Axe-Edit etc.) do not have a border around the main window,
like the Preferences popup window above.  These borders typically surround the window and 
place a thicker “Title Bar” across the top of the window.  Deselecting this option will cause 
these borders to be hidden.  Popup windows always have the borders shown so that they can 
be grabbed and moved around the screen.  The main window can be moved by clicking the 
mouse anywhere in the window and dragging it to a new location.

Open last file on startup
When this option is selected MFC-Edit will automatically open the last edited file when it is 
launched.

Check for update on startup
When this option is selected MFC-Edit will contact the Fractal Audio Systems' servers to see if 
any update is available.  If the update is available you are given the option to download and 
install it.  If this option is not selected then no check for updated version is performed.  You can 
still manually check for updates off the Help menu.

Show extended balloontip help
Many of the user interface elements have a “tooltip” which shows a terse and somewhat helpful
tip when you hover the mouse over it.  For people who work with MFC-Edit often this is usually 
sufficient but for those less familiar selected the extended balloontips will cause a  “balloon” to 
pop up with a more meaningful help message.  You can also always right-click the mouse to 
get context-sensitive help displayed.
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Delay before showing balloontip
When the “Delay before showing balloontip” is selected a “spinner” is displayed allowing you to 
select the number of milliseconds that a mouse cursor must hover over an element before the 
balloontip will popup.

Ask for confirmation when quitting with unsaved changes
Like it says – if you quit the MFC-Edit program and you have made edits that are not yet saved 
then you are prompted if you really want to quit and discard your changes, save the changes or
not quit and continue editing.

PRESETS tab

Copy Axe-Fx preset name to MFC-101
When on the PRESETS & EXT. DEVS page of MFC-Edit you can choose to select a different 
Axe-Fx preset than the MFC-101 preset. By default, the MFC-101 preset #31 would select Axe-
Fx preset #31 also, but you may wish to change this behavior.  For example, if you wanted 
MFC-101 preset #31 to select Axe-Fx preset #502 then you would have to change the default 
on the PRESETS & EXT. DEVS page.  Selecting this option causes the Axe-Fx preset name to 
be copied to the MFC-101 preset name if you change the MFC-101 to Axe-Fx preset 
assignment.  It makes it a lot easier to remember which Axe-Fx preset is called up if the MFC-
101 preset name is descriptive.

Use list to edit the custom MIDI message
There are three ways to enter Custom MIDI message bytes into each preset; type them into the
locations (the default), paste the bytes from the clipboard or click on each byte in the message 
to select the hexadecimal value from a list.  Select this option if you want to edit message bytes
by picking them from the list instead of entering them from the keyboard.  You can always 
paste message bytes from the clipboard by right-clicking the mouse in the Custom MIDI 
message field and choosing the “Paste MIDI message from clipboard” option.

SONGS & SETS tab

Popup Axe-Fx Presets palette each on SONGS page
There is a handy popup window available showing all the Axe-Fx preset names and numbers 
to assist with entering songs.  From this palette you can copy/paste and drag/drop songs into 
the MFC-101's SONGS page.  You can access this palette from the Tools menu at any time, 
but you can have it automatically pop up each time you select the SONGS page by selecting 
this option.

Show Friendly Song names on SONGS and SETS pages
The MFC-101 equipment has song names that can be a maximum of 7 characters in length.  
This is a sever limitation and makes it sometimes difficult to find a meaningful 7-letter 
abbreviation for song names – for example “I Feel Like Making Love”.  MFC-Edit allows you to 
have longer song names, up to 25 characters long.  Selecting this option lets you work with the 
“Friendly Names” (long names) rather than or in addition to the short names in the SETS and 
SONGS pages.

Popup Songs palette on SETS page
There's a handy Songs palette that you can pop up from the Tools menu.  You can use this as 
a reference or drag and drop songs from this palette to the Sets.  Selecting this option will 
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automatically pop up the Songs palette any time you select the SETS page and pop it down 
again when you leave the SONGS page.

Double-click for drop-down on SETS page
In nearly every place that there is a drop-down list in MFC-Edit it is expedient to have the list 
drop down with a single mouse-click.  The SETS page is different because if all you want to do 
is drag and drop a song to another slot or another set clicking the mouse would drop-down the 
list.  This becomes annoying and makes drag and drop a chore.  Selecting this option will 
require you to double-click a Song on the SETS page before the drop-down list appears. A 
single-click and mouse movement is an easy way to drag Songs around around Sets.

Duplicate Song behavior
When inserting a Song into a Set on the SETS page that is already in that set, how do you 
want MFC-Edit to behave?  Your choices are “Warn me”, “Disallow it” and “Allow it”.

VIRTUAL MFC-101 tab

Always Popup on BASE CONFIG page
If you want the Virtual MFC-101 to always popup when you select the BASE CONFIG tab of 
the main interface, select this option.

Always Popup on IA SWITCHES  page
If you want the Virtual MFC-101 to always popup when you select the IA SWITCHES tab of the 
main interface, select this option.

Preset Overlay Line Color
Use this list to select the color if the line you want to surround the Preset switches with.

PATHNAMES tab

MFC-Edit Installation
This is where the MFC-Edit program is installed.  You cannot change it.

MFC-Edit UserHome
For each user using the MFC-Edit program there will be a folder called “MFC-101” created 
below their “Home” folder the first time they run MFC-Edit.  It is below this folder where MFC-
Edit keeps is documentation, SysEx dumps and “template” or “stock” dumps.  You can change 
it freely from the default.

Fractal Bot
If Fractal Bot is installed on your computer its location is noted here so that you can launch it 
from the Tools menu of MFC-Edit.  If Fractal Bot is not found in the default location you can 
change its location here.

Axe-Edit
If Axe-Edit is installed on your computer its location is noted here so that you can launch it from
the Tools menu of MFC-Edit.  If Axe-Edit is not found in the default location you can change its 
location here.

Thank you for choosing MFC-Edit from Fractal Audio Systems
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AXE-FX III ADDENDUM
March 20th, 2018

DISCLAIMER:  MFC-Edit was designed with the Axe-Fx II in mind, when the Axe-Fx III did not 
exist.  The MFC-101 also was designed long before the Axe-Fx III existed so limitations exist in the
MFC-101 controller platform itself with regard to leveraging the full feature set and power of the 
Axe-Fx III.  Lastly, I have not tested the MFC-101 or MFC-Edit with an Axe-Fx III so I cannot 
warrant the functionality.  I will make every effort, based on feedback from users, to update this 
document and where possible the MFC-Edit program to ease the transition until such time as the 
FC-6 and FC-12 are in general availability.  Axe-Fx III interoperability may or may not be supported
beyond general availability of the FC-series controllers.

The MFC-101 can be used with the Axe-Fx III – while you wait for the new FC-6 and FC-12 to 
become available.  Please note that the FC-6/12 are purpose-built as the companion Foot 
Controllers for the Axe-Fx III and no other controller will leverage the Axe-Fx III’s awesome 
features as well as the upcoming FC series.  The FC-6 and the FC-12 are the preferred foot 
controllers for the Axe-Fx III but until they are available it is possible to use the MFC-101.

More information on the FC-6 and FC-12 can be found here: FC-6/12 Fractal Wikipedia  

( https://wiki.fractalaudio.com/axefx2/index.php?title=FC-6_and_FC-12_foot_controllers )

I have made some changes to MFC-Edit v8.0 in order to make programming the MFC-101 a little 
easier for use with the Axe-Fx III.  Please note that the MFC-101 firmware has not changed!  
The firmware of the MFC-101 has not been enhanced to support the Axe-Fx III so you should 
expect some limitations and constraints while using the MFC-101 to control your Axe-Fx III.

In order to understand the rationale for the MFC-Edit changes I need to first provide a little 
background on the Axe-Fx III and the MFC-101.

The MFC-101 is essentially a foot controller that sends MIDI commands via MIDI cable or via 
the EXPANSION (Ethercon) or FASLINK cables.  It has its own processor, firmware and local 
memory – in short – it has its own “intelligence” where the firmware instructions are executed.  The
MFC-101 has some pretty complex and capable software/firmware and hardware where a lot of 
processing is done and then ultimately some MIDI sequence is sent to the connected Axe-Fx or 
other device.  The FC-6 and FC-12 on the other hand are sort of “dumb terminals” - all the 
processing for the FC-6 and FC-12 are performed in the Axe-Fx III itself, as are the programming, 
behavior and configuration of the foot controller.  Unlike the MFC-101, the FC-6 and FC-12 do not 
use the MIDI protocol to communicate with the Axe-Fx III – they instead use a proprietary protocol.

The Axe-Fx, Ultra, II, II XL and II XL+ all respond to these MIDI commands received from the MFC-
101.  These MIDI commands, Control Change (CC) and Program Change (PC) commands 
are predefined in the Axe-Fx/Ultra/II/II XL and XL+ (though they can be changed).  So when you
select the “Axe-Fx Mode” in the MFC-101 or on the BASE CONFIG page of MFC-Edit, the MFC-
101 “knows” what default MIDI commands to send to the Axe-Fx to control Effect Blocks etc.  
(Permit me simplification for the sake of brevity).

The Axe-Fx III has no such predefined set of commands.  This is by design – the Axe-Fx III 
essentially has more features than the MIDI spec provides for.  That’s a problem.  It means that 
using only MIDI you couldn’t control every feature of the Axe-Fx III at the same time (or at least, not
without performing some herculean complexities with MIDI that wouldn’t really be sustainable). So, 
unlike the earlier Axe-Fx models, your available MIDI controls are not preassigned to stuff you 
might never use – you are free to use them as you see fit – to best suit each person’s need.  
Having no predefined CC assigned to controls and effect blocks/bypass etc. means that 
connecting your MFC-101 to an Axe-Fx III would be almost like speaking gibberish – it would mean
nothing at all to the Axe-Fx III and no predictable action would performed.  
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I will not address how the FC-6 and FC-12 function here but you can read more about them on the 
Fractal Audio Systems Wiki for the FC-6 and FC-12 found here: 
https://wiki.fractalaudio.com/axefx2/index.php?title=FC-6_and_FC-12_foot_controllers

There are a few crucial things to know if you intend to use your MFC-101 with the Axe-Fx III:

• There is no “Axe-Fx III” mode in the MFC-101 firmware (Section 3.1 of MFC-101 Owner’s 
Manual)  This is “faked” in MFC-Edit v8.0 as an assistive nicety

• The MFC-101 is essentially operating in Axe-Fx Mode = NONE

• The MFC-101 can connect to the Axe-Fx III only via MIDI cables

• There are no preassigned CC#s in the Axe-Fx III – you   have to   assign them yourself   (see 
Chapter 12 of the Axe-Fx III Owner’s Manual. Pay attention to the CC value vs. the CC 
number as you read these pages).  If you’re used to using your IA Switches to turn effects 
on/off (bypass) in your earlier Axe-Fx model then particularly read the MIDI/REMOTE: 
BYPASS PAGE in chapter 12 of the Axe-Fx III Owner’s Manual

• Don’t expect the Axe-Fx III to work just like the Axe-Fx II on steroids – it really is a big leap 
ahead and while the paradigm is much the same, you will enjoy a learning curve with great 
rewards for your efforts

So, finally, after much ado, here are the MFC-Edit changes…

The Axe-Fx III option has been added to the “Axe-Fx Mode” drop-down on the BASE CONFIG 
page:

Selecting the Axe-Fx III option is almost equivalent to selecting the None option.  The differences 
from the “None” option are:

• The MIDI port is automatically selected for you on the MIDI & CHANS page. This tells the 
MFC-101 to communicate over the MIDI cables only – EXPANSION/Ethercon and 
FASLINK connections are not possible between the MFC-101 and the Axe-Fx III. As such, 
the MFC-101 must be powered by the transformer for use with the Axe-Fx III.
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• On the IA SWITCHES page, the Axe-Fx Func column (3rd from the left) pre-populates the 
c1 column when an Effect is selected from the drop-down list. This means that the first 
Control Change will be set to a value (the MFC-101 can send two CC#s per switch press)

• On the IA SWITCHES page, the Send w/prst (send with preset) column is automatically 
set to “No”. You can change that if you want to

IMPORTANT NOTE: The CC# that is placed into the c1 column is the same as the default CC# 
found in the Axe-Fx II/XL/+.  If you have set your CC# to a different number in the Axe-Fx III then 
you can easily enter that number into the c1 column and override the default.  I chose to use the 
Axe-Fx II values by default because many people will be familiar with them already and it also 
helps those Axe-Fx II/XL/+ users who don’t use the “Axe-Fx Mode” feature and instead program 
their controller manually.

Following is a complete list of the CC#s that are populated into the c1 column when their 
corresponding Axe-Fx Function is selected.  This list can also be viewed from within MFC-Edit by 
going to the Tools menu bar at the top of the main window and selecting Tools→Show CC 
Assignments.
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The Initial On/Off State of each IA Switch is not read from the Axe-Fx III via MIDI so you’ll need 
to set those manually on your MFC-101.  Here’s one suggested workflow for doing that:

1. Transmit your configuration to the MFC-101
2. Load a desired preset via your MFC 
3. Manually set all footswitches where you want them when the preset loads
4. Press SAVE EDITS switch
5. Re-load preset to test

Another method of setting the initial on/off value would be to do so in the MFC-Edit software from 
the PRESETS & EXT. DEVS page.  There is a “push-button” on this page for each of the IA 
Switches (not the INT. CC) – set these switches to their On/Off states so that they match the block 
state in that preset in the Axe-Fx III.  Please see screenshot below.
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